Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2004
    Posts
    27

    Sputtering when stomping on it...??? Help..

    I have a weiand 144 on a 400 sbc which runs fine under normal to medium throttle, but really begins to sputter when i stomp on it. I'm running around 8psi of boost w/ the blue holley fuel pump, fram race filter and holley 750 vacuum secondary. I can't seem to figure out what the real prob. is although i keep tweaking the jets and timing but haven't gotten it fixed yet.

    Thanks for the feedback in advance.

    Ryan

    Light the fires and smoke the tires!!!


  2. #2
    Join Date
    Jul 2005
    Posts
    328
    I think I remember that drilling very small holes in the flaps in the carb makes the stumble go away, but also make sure the power valves are correct for a blower.

  3. #3
    Join Date
    Aug 2004
    Location
    Milwaukee, Wi.
    Posts
    326
    My vote is to go to a 750 with mechanical secondaries. Boosted motors need LOTS of fuel! The vac. secondaries don't have jets that you can change.Make sure you check your fuel pressure under boost so you don't go lean. (detonation= bad, see BIG KABOOM!)
    Steve

  4. #4
    Join Date
    Dec 2004
    Posts
    27
    problem solved. I manifold referenced the power valve. charger was sucking power valve closed. fast as hell now. thanks, and if anyone has same prob. drop me a line i'll let you know how to do [email protected]


    later.
    ryan
    Light the fires and smoke the tires!!!