Enter your username:
Do you want to login or register?
  • Forgot your password?

    Login / Register



    Results 1 to 4 of 4
    1. #1
      Join Date
      Oct 2004
      Location
      IL/TN
      Posts
      848
      Country Flag: United States

      Not seeing site sponsors.

      anyone else having trouble with Google Chrome and PT.com? advertise banners and individual forum sponsors not visible, Firefox seems to work fine
      https://www.pro-touringf-body.com "doing what they say can't be done"

    2. #2
      Join Date
      Sep 2010
      Location
      Beach Park IL
      Posts
      2,586
      Country Flag: United States
      Its part of Googles plans to steal your advertising dollars. If they don't show the advertisements you paid for, you will be compelled to advertise with Google directly. It will greatly increase their bottom line and further help them to take over the world.

      or

      Your adblocker is on, maybe try turning it off.
      Donny

      Support your local hot rod shop!

    3. #3
      Join Date
      Nov 2006
      Location
      Mountain Springs, Texas
      Posts
      3,926
      Country Flag: United States
      My ad blocker removes the forum sponsors.

      Don
      1969 Camaro - LSA 6L90E AME sub/IRS
      1957 Buick Estate Wagon
      1959 El Camino - Ironworks frame
      1956 Cameo - full C5 suspension/drivetrain

    4. #4
      Join Date
      Oct 2004
      Location
      IL/TN
      Posts
      848
      Country Flag: United States
      I need to look a bit deeper, GC has also blocked my Fedex manager as if fedex didn't cause me MAJOR heartburn already.

      https://www.pro-touringf-body.com "doing what they say can't be done"