Enter your username:
Do you want to login or register?
  • Forgot your password?

    Login / Register



    Results 1 to 14 of 14
    1. #1
      Join Date
      Nov 2010
      Posts
      249

      Stand alone harness

      I installed a PSI harness and ECU and have had nothing but issues. Dealing with PSI has been a pain and nothing is ever their fault. I have thrown who knows how many parts at the car at their recommendation and still have the same issue. I finally took it to a shop and they said my issue is in the engine harness (PSI) and rather than chasing down the harness problem it would be cheaper to pull the harness and put a new one in. The ECU has already been replaced and itís not a PSI one (done at their recommendation). All I need is a harness, any recommendations? Also, if youíre thinking about buying from PSI shoot me a line and Iíll tell you the issues Iíve had with them.

    2. #2
      Join Date
      Nov 2006
      Location
      Mountain Springs, Texas
      Posts
      3,926
      Country Flag: United States
      I have had good luck with Speartech. They are not the lowest cost but their stuff just works.

      Don
      1969 Camaro - LSA 6L90E AME sub/IRS
      1957 Buick Estate Wagon
      1959 El Camino - Ironworks frame
      1956 Cameo - full C5 suspension/drivetrain

    3. #3
      Join Date
      Aug 2004
      Location
      Central Florida
      Posts
      456
      Quote Originally Posted by dhutton View Post
      I have had good luck with Speartech. They are not the lowest cost but their stuff just works.

      Don
      I'm with Don on this one .... After much research and talking with the guys at Speartech we purchased a harness and ECU to drive a LS7 w/ 4L80E. We haven't run it yet ( just got it a few weeks ago and getting ready to start on the project soon) but the harness looks very well laid out with quality harness cover not some plastic wire loom as seen on other conversions kits.
      Give them a call and see if they can help you out



      BB


    4. #4
      Join Date
      Sep 2017
      Posts
      502
      Country Flag: United States
      Quote Originally Posted by firebirdzig View Post
      I installed a PSI harness and ECU and have had nothing but issues. Dealing with PSI has been a pain and nothing is ever their fault. I have thrown who knows how many parts at the car at their recommendation and still have the same issue. I finally took it to a shop and they said my issue is in the engine harness (PSI) and rather than chasing down the harness problem it would be cheaper to pull the harness and put a new one in. The ECU has already been replaced and itís not a PSI one (done at their recommendation). All I need is a harness, any recommendations? Also, if youíre thinking about buying from PSI shoot me a line and Iíll tell you the issues Iíve had with them.
      Crap I just ordered one 3 weeks ago from PSI and haven't received it yet. For LS7 also.
      Hope I have better luck.
      TANKMASTERJ

    5. #5
      Join Date
      Aug 2004
      Location
      NJ
      Posts
      1,274
      Country Flag: United States
      LSX Specialties gets my vote. I've heard good things about Speartech also.

      The feedback on PSI is hit or miss.

    6. #6
      Join Date
      Feb 2016
      Location
      SoCal
      Posts
      466
      What ecu and trans are you running? I may have something on the shelf ready to go. If not, its 12 weeks to make one....
      1970 VW Bug - Just your average mid engine Bug
      Track toy - 06 Evo - E85 and lots of boost
      Newest track toy - 2021 Supra

    7. #7
      Join Date
      Nov 2010
      Posts
      249
      I have an e38 ecu, 58x, and an 02 fbody t56.

    8. #8
      Join Date
      Apr 2010
      Location
      Cove, Texas
      Posts
      65
      Country Flag: United States
      Try BP Automotive. Bill has harnesses in stock. Just ordered two of them. They were here in about a week...

      T,

    9. #9
      Join Date
      Jul 2007
      Location
      Phx AZ
      Posts
      25
      Country Flag: United States
      Speartech reworked my stock LS2 GTO harness that’s in my Nova 10 years ago before they were doing stand alone. I have never had an issue with it.

    10. #10
      Join Date
      Mar 2009
      Location
      Houston, TX
      Posts
      1,189
      Country Flag: United States
      Quote Originally Posted by firebirdzig View Post
      I installed a PSI harness and ECU and have had nothing but issues. Dealing with PSI has been a pain and nothing is ever their fault. I have thrown who knows how many parts at the car at their recommendation and still have the same issue. I finally took it to a shop and they said my issue is in the engine harness (PSI) and rather than chasing down the harness problem it would be cheaper to pull the harness and put a new one in. The ECU has already been replaced and itís not a PSI one (done at their recommendation). All I need is a harness, any recommendations? Also, if youíre thinking about buying from PSI shoot me a line and Iíll tell you the issues Iíve had with them.
      Curious to know what issue you're having? Maybe someone here can have you diagnose and fix it, if you're up to it, instead of buying a new harness?
      Tu Ho
      Firebird V2-LS swap

    11. #11
      Join Date
      Nov 2010
      Posts
      249
      The ecu is randomly losing power from the harness from the main power cable that is hooked up to the starter. The shop jumped both the ignition power and main power. It stopped the car from randomly dying while driving. (You would be driving, feel a shutter and then the ecu would shut off. Radio, gauges, lights ect would all stay on but the ecu would turn off. We caught it while my tuner was hooked up and we were drive tuning the car and you could see right before the ecu turned off it lost power.) The pedal would also randomly go dead but not throw any codes. PSI has been zero help except for helping me throw money at a new throttle body, rewiring a bunch of stuff that I wired, a new alternator ect ect ect. Nothing has been their fault. My tuner even gave me a new ecu and we tuned that ecu and still had the same issues. The shop tested everything and narrowed it down to the PSI harness. The next step would be to pull the harness, unwrap the wires, and chase all of them down to find the short/ bad crimp/ whatever it is that is causing the problem. The shopís recommendation was for me to take the car, pull the harness and either put in a new harness or the Holley Terminator. The other option was to leave it with them and they could chase the problem or put in a new harness but it would cost me a lot more at this point than to just take it and do it myself.

    12. #12
      Join Date
      Nov 2010
      Posts
      249
      Quote Originally Posted by TANKMASTERJ View Post
      Crap I just ordered one 3 weeks ago from PSI and haven't received it yet. For LS7 also.
      Hope I have better luck.
      I would see if you can cancel your orderÖ

    13. #13
      Join Date
      Nov 2010
      Posts
      249
      Quote Originally Posted by rickpaw View Post
      Curious to know what issue you're having? Maybe someone here can have you diagnose and fix it, if you're up to it, instead of buying a new harness?
      I replied separately, it didnít attach to your comment. My bad

    14. #14
      Join Date
      Sep 2017
      Posts
      502
      Country Flag: United States
      Quote Originally Posted by firebirdzig View Post
      I would see if you can cancel your orderÖ
      Wish I could but has arrived. I'm a few months away from trying it. I still got to install my Wegner accessories drive and the rain gear wiper kit before I can slide my subframe back under the car. Hopefully I do t have these problems.
      Jaaon
      TANKMASTERJ