Enter your username:
Do you want to login or register?
  • Forgot your password?

    Login / Register



    Results 1 to 16 of 16
    1. #1
      Join Date
      Jun 2010
      Location
      Deployed
      Posts
      3,263
      Country Flag: United States

      Starter Slow to Operate when warm

      When I have driven my car around for a while and up to temps, if I shut the car off, the starter is slow to crank almost like the battery is dead. Once everything cools off it works like a charm. I recently bought a thermal blanket for it, but it hasn't made a difference in how it acts. What could be the issue? Bad Starter?
      1970 Camaro/DSE build


      Are you driver enough? Maybe....come on blue!
      https://www.pro-touring.com/threads/...71#post1147371

    2. #2
      Join Date
      Sep 2010
      Location
      Beach Park IL
      Posts
      2,490
      Country Flag: United States
      Blankets are just as good at holding heat in as keeping it out.

      Check all cable connections and grounds. Not just visually, bet remove and clean those contacts and make sure they are tight. After that, throw a starter at it if the problem persists.
      Donny

      Support your local hot rod shop!

    3. #3
      Join Date
      Feb 2011
      Location
      dallas, tx
      Posts
      1,678
      Country Flag: United States
      Dealt with this for a year. Some times it would just click and not start. I bought a new gm starter, factory heat shield, and connectors. Zero issues since. Same issue with another guy and he did the same thing I did and he hasn’t had any more issues either. Sadly the boshe starter before the gl starter was maybe a year old.

    4. #4
      Join Date
      Jun 2010
      Location
      Deployed
      Posts
      3,263
      Country Flag: United States
      Quote Originally Posted by icemanrd19 View Post
      Dealt with this for a year. Some times it would just click and not start. I bought a new gm starter, factory heat shield, and connectors. Zero issues since. Same issue with another guy and he did the same thing I did and he hasn’t had any more issues either. Sadly the boshe starter before the gl starter was maybe a year old.

      Which one did you use? I notice that the LS3 Camaro and the 2015 Z28 Ls7 version has the same heat shield, but the starter is a different part #

      What could be the difference between an LS3 and LS7 starter? The starter Im looking at is only 2013-2015 LS7 Camaro?
      1970 Camaro/DSE build


      Are you driver enough? Maybe....come on blue!
      https://www.pro-touring.com/threads/...71#post1147371

    5. #5
      Join Date
      Jun 2010
      Location
      Deployed
      Posts
      3,263
      Country Flag: United States
      Quote Originally Posted by badazz81z28 View Post
      Which one did you use? I notice that the LS3 Camaro and the 2015 Z28 Ls7 version has the same heat shield, but the starter is a different part #

      What could be the difference between an LS3 and LS7 starter? The starter Im looking at is only 2013-2015 LS7 Camaro?

      deal was too good to pass up

      https://www.ebay.com/vod/FetchOrderD...=1749072534019
      1970 Camaro/DSE build


      Are you driver enough? Maybe....come on blue!
      https://www.pro-touring.com/threads/...71#post1147371

    6. #6
      Join Date
      Apr 2001
      Location
      The City of Fountains
      Posts
      15,255
      Country Flag: United States
      I used a 2010 Camaro starter on my Cougar. It has the provisions for the heat shield which I got from the dealer. I do recall having to grind the inside of the starter pocket on the f-body bell housing that I am using, but it was very minor and I did it with a small flapper wheel on my Dremel tool.

      Andrew
      1970 GTO Version 2.0
      1967 Cougar build
      GM High-Tech Performance feature
      My YouTube Channel Please Subscribe!
      Instagram @projectgattago
      Dr. EFI
      I deliver what EFI promises.
      Remote Holley EFI tuning.
      Please get in touch if I can be of service.

      "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her

    7. #7
      Join Date
      Aug 2007
      Location
      Jonesboro, Arkansas
      Posts
      2,455
      Country Flag: United States
      what motor you running? Forged pistons?
      The reason I'm asking is about 35 years ago I built a 350 with forged pistons. I didn't like the way they rattled in the block when running so I had the bores a little tight. When it heated up the forged pistons swelled and caused some tight fitting inside the cylinder walls. Like to of never figured it out though. I figure this isn't your problem but it sure gave me a fit..


      Carl Wilson
      1968 Camaro - T-56 6 speed - 383 Stroker, 2014 Mustang GT seats


    8. #8
      Join Date
      Jun 2010
      Location
      Deployed
      Posts
      3,263
      Country Flag: United States
      It’s an LS7, I’m assuming since it’s a higher compression engine the starter is not liking it?
      1970 Camaro/DSE build


      Are you driver enough? Maybe....come on blue!
      https://www.pro-touring.com/threads/...71#post1147371

    9. #9
      Join Date
      Feb 2011
      Location
      dallas, tx
      Posts
      1,678
      Country Flag: United States
      Stop overthinking it like I did. Get a oem starter with a oem heatshield

    10. #10
      Join Date
      Apr 2001
      Location
      The City of Fountains
      Posts
      15,255
      Country Flag: United States
      Quote Originally Posted by icemanrd19 View Post
      Stop overthinking it like I did. Get a oem starter with a oem heatshield
      It's a LS7, not a 15:1 nitrous big block.

      Quote Originally Posted by badazz81z28 View Post
      Itís an LS7, Iím assuming since itís a higher compression engine the starter is not liking it?
      ^^^this
      1970 GTO Version 2.0
      1967 Cougar build
      GM High-Tech Performance feature
      My YouTube Channel Please Subscribe!
      Instagram @projectgattago
      Dr. EFI
      I deliver what EFI promises.
      Remote Holley EFI tuning.
      Please get in touch if I can be of service.

      "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her

    11. #11
      Join Date
      Feb 2014
      Posts
      196
      Country Flag: United States
      Hi Andrew, for the 2010 camaro starter that you are using, would it matter which transmission is used? I have a 2006 lq4/4l80e transmission and was wondering if your starter would work.

    12. #12
      Join Date
      Apr 2001
      Location
      The City of Fountains
      Posts
      15,255
      Country Flag: United States
      I'm using a 4th gen Camaro T56 and bellhousing. I don't know how it might work with a 4L80e. The amount of material that I removed was minimal. It literally took 10 minutes and a couple of trial fittings.

      Andrew
      1970 GTO Version 2.0
      1967 Cougar build
      GM High-Tech Performance feature
      My YouTube Channel Please Subscribe!
      Instagram @projectgattago
      Dr. EFI
      I deliver what EFI promises.
      Remote Holley EFI tuning.
      Please get in touch if I can be of service.

      "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her

    13. #13
      Join Date
      Feb 2014
      Posts
      196
      Country Flag: United States
      Quote Originally Posted by andrewb70 View Post
      I'm using a 4th gen Camaro T56 and bellhousing. I don't know how it might work with a 4L80e. The amount of material that I removed was minimal. It literally took 10 minutes and a couple of trial fittings.

      Andrew
      I was more concerned with the flexplate spacing for the 4l80e, not sure if this would be an issue.

      thanks!

    14. #14
      Join Date
      Apr 2001
      Location
      The City of Fountains
      Posts
      15,255
      Country Flag: United States
      Quote Originally Posted by BlackHD View Post
      I was more concerned with the flexplate spacing for the 4l80e, not sure if this would be an issue.

      thanks!
      That's a non-issue.
      1970 GTO Version 2.0
      1967 Cougar build
      GM High-Tech Performance feature
      My YouTube Channel Please Subscribe!
      Instagram @projectgattago
      Dr. EFI
      I deliver what EFI promises.
      Remote Holley EFI tuning.
      Please get in touch if I can be of service.

      "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her

    15. #15
      Join Date
      Feb 2014
      Posts
      196
      Country Flag: United States
      thanks!

    16. #16
      Join Date
      Jun 2010
      Location
      Deployed
      Posts
      3,263
      Country Flag: United States
      I bought the 14-15 Z28 LS7 starter. Its smaller than your typical LS series starter and upon further research its the starter used on the new LT engines. It has a different connector on the solenoid which would explain why its application specific for only the 14-15 Z
      1970 Camaro/DSE build


      Are you driver enough? Maybe....come on blue!
      https://www.pro-touring.com/threads/...71#post1147371