Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2017
    Posts
    59

    68 Chevelle Rear Bumper

    I'm hoping someone will have experienced (hopefully not, but would help me )the same thing. I bought rear bumper for my 68 Chevelle and this is what I have;

    1. Width of my frame is 43 3/16" outside face to outside face. Its the outside face the bumpers attached to. I confirmed this dimension with GM spec sheets.

    2. I have attached some photos showing how far off the brackets are from mounting to the outside face of the frame. The first two photos show me holding the bumper up to the frame with the one bracket lined with the outside face and the second photo shows how far off it is on the other side, 2.25" to be exact.

    3. The third photo shows two tabs, one hole in the chrome bumper and the second slotted hole in the powdercoated licence plate frame. These need to be bolted together as per the instruction, last photo.

    4. The fourth photo shows 6 tabs across the bottom of the bumper. The inside two holes are roughly 31-1/4 center to center, the two middle holes are 45 and the two outer holes are 56 apart.

    5. This photo is from the installation manual. So I don't think I missed the boat on this one.

    Would someone be kind enough to check your rear bumper against #4 above. I'm working with the supplier in Florida as well but I wanted to get some feed back here first. Thanks in advance.

    Perry
    Attached Images Attached Images          

  2. #2
    Join Date
    Sep 2017
    Posts
    59
    Wow, 124 views and no one is able to help. All I'm looking for is 3 dimensions. There's 6 tabs on the bottom of the bumper. I'm looking for the center of hole to center of hole dimensions on the two outer holes, the two middle holes and the two inner holes. I have a 68 chevelle. It will only take a total of 10 minutes of your time to measure and post the info. I'm really asking for help no thank you!!!

    - - - Updated - - -

    I meant thank you!! Dam auto correct.

  3. #3
    Join Date
    May 2010
    Location
    kitchener,Ontario,Canada
    Posts
    1,929
    Country Flag: Canada
    Relax a min lol ... this might as well be a Camaro forum lol. My guess would be ... wrong brackets , or something to that extent . Only advice I can offer is to make sure all bolts are loose in the brackets and try to bolt the bumper up then ???
    Spinnin'my tires in life's fast lane

    Ryan Austin
    On twitter @raustinss
    On Instagram austinss70

  4. #4
    Join Date
    Sep 2017
    Posts
    59
    I never would have guess that by loosening the bolts would cover 2 of misalignment. Appreciate the help.

    Perry
    Attached Images Attached Images  

  5. #5
    Join Date
    May 2010
    Location
    kitchener,Ontario,Canada
    Posts
    1,929
    Country Flag: Canada
    Hey awesome , glad it worked out for you . Cheers
    Ryan

    Spinnin'my tires in life's fast lane

    Ryan Austin
    On twitter @raustinss
    On Instagram austinss70