Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2014
    Location
    Wisconsin
    Posts
    18
    Country Flag: United States

    LSA swap in 1st gen - Upper Radiator Hose with CTS-V Water Pump

    Good morning everyone. I've done some searches and it seems all the recommended radiator hoses posts come from those with a standard vette or F-body water pump. The LSA/CTS-V water pump outlet is further away from that typical passenger side radiator location for the upper hose which means that NAPA part number is quite a bit short.

    What part numbers has everyone been using? I am looking for a molded hose, not an AN fitting setup. If it comes to it I'll just cut the NAPA hose and put a fill/cap in to extend it that 4-5" that I need but wanted to check with everyone here first.

    Thanks!

  2. #2
    Join Date
    Jan 2007
    Location
    CT
    Posts
    784
    Country Flag: United States
    i used 71989 hose which needed to be cut to size but fit nice.
    ________________
    Nick S.
    Gold/Gray 1967 Camaro

  3. #3
    Join Date
    Sep 2014
    Location
    Wisconsin
    Posts
    18
    Country Flag: United States
    Thanks Nick. Do you have an engine bay pic of your car? I tried searching your old posts but didn't seem like they loaded the pics. Just ordered it to try out since its cheap.

    Thanks!

  4. #4
    Join Date
    Jan 2007
    Location
    CT
    Posts
    784
    Country Flag: United States
    this is the best i could find of it.


    ________________
    Nick S.
    Gold/Gray 1967 Camaro