Results 1 to 7 of 7
  1. #1
    Join Date
    Nov 2005
    Location
    livermore ca
    Posts
    718

    lt1 fuel return line question

    i am new at building lt1 motors and dont quite understand somthing maybe u can help me out.

    do lt1 fuel injection motors need a return line? for some reason i think i saw on some post that they do so i was going to run a fuel sump on my stock tank and run a msd elecric fuel pump but i dont know if i need that sump if i dont need a return line?

  2. #2
    Join Date
    Jul 2005
    Location
    Eastern Virginia
    Posts
    3,920
    Country Flag: United States
    You do need a return line. I used the factory return line on my Monte for it. Factory LT1 cars use 5/16 line.
    Scot
    86 Monte SS
    Soon to get a near 500hp LS2/T56
    https://www.pro-touring.com/showthre...getting-an-LS2

  3. #3
    Join Date
    Nov 2005
    Location
    livermore ca
    Posts
    718
    ya thats what i thought thanks il have to get that sump becuase it has a return line an fitting on it and my stock tank dose not becuase the motor is goin in to a 65 chevelle

  4. #4
    Join Date
    Jan 2005
    Location
    Mantorville, MN
    Posts
    775
    Country Flag: United States
    Can you guys post pics of your LT1 installs? I'm doing the same right now and need some ideas and inspiration to keep making progress.

  5. #5
    Join Date
    Jul 2005
    Location
    Eastern Virginia
    Posts
    3,920
    Country Flag: United States
    My guess is the opening in the tank is the same as what the Monte is. Couldn't you just get a sending unit from something with fuel injection & use the return connection from it & run the line in the same fashion as the feed line?

    Scot

    Scot
    86 Monte SS
    Soon to get a near 500hp LS2/T56
    https://www.pro-touring.com/showthre...getting-an-LS2


  6. #6
    Join Date
    Nov 2005
    Location
    livermore ca
    Posts
    718
    i could but i dont belive it is that simple. ill just run the sump run the line to my fuel rails and then run a line from the other rail to the fuel pressuer regulator and from the regulator to the return line coming out of the sump

  7. #7
    Join Date
    Nov 2005
    Location
    livermore ca
    Posts
    718
    Quote Originally Posted by Derek69SS
    Can you guys post pics of your LT1 installs? I'm doing the same right now and need some ideas and inspiration to keep making progress.

    i have not installed mine yet im still getting things ready so i can install it


    here is a pic of the motor but all the goodies that go on it are not on in this pic