Page 2 of 2 FirstFirst 1 2
Results 21 to 26 of 26
  1. #21
    Join Date
    Apr 2001
    Location
    The Druid City
    Posts
    13,463
    Country Flag: United States

    Default

    Quote Originally Posted by TheJDMan View Post
    You put "Seafood" in the gas? Hmm, I learn something new everyday!
    All the cool kids are doing it :-/
    1970 GTO Version 2.0
    1967 Cougar build
    GM High-Tech Performance feature
    My YouTube Channel Please Subscribe!

    "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her


  2. #22
    Join Date
    Apr 2001
    Location
    The Druid City
    Posts
    13,463
    Country Flag: United States

    Default

    I thought I would update y'all on my truck. I finally took it into the local Mazda dealership (reluctantly). One of their techs managed to break the EGR tube...sigh.

    Finally the truck was given to their lead tech. I talked to him and he seemed sharp enough. Long story short, he concluded that right after the truck dies, there is no compression in the #1 cylinder. This of course leads to the diagnosis of recessed valve seats.

    I didn't trust them to do the work, so I got in touch with my buddy Joseph, who actually lives in Memphis. He is a mechanic and does work on the side. The plan was to drive to Memphis, eat BBQ, and work on the truck together over a weekend.

    I collected parts from RockAuto. I got a new (rebuilt) head, all relevant gaskets, new plugs, wires, coils, water pump, upper water neck, new timing belt and tentioner, new head bolts. Made the trip to Memphis and we started the work.

    Everything was going OK until we got to removing the head. The worst scenario happened and one of the head bolts broke. Luckily, there was enough showing to weld a nut and extract (this happened after calling a buddy, him bringing a welder, Joseph rewiring a 220v outlet in the kitchen for a proper socket, and us hanging the welder out the window to weld the nut...LOL).

    Reassembly went smoothly, got everything together, had some minor issues with the timing belt (apparently I need to go back to pre-school and learn the difference between a diamond and a triangle shape). Long story short...

    The rough idle problem is gone, but now I have a new problem. The engine has a mysterious stumble. It presents itself in several ways:

    1) At idle, if you quickly blip the throttle, the engine shakes and stumbles, then revs up.
    2) Taking off in 1st gear (manual trans) if the engine is lugged down a little too much, it will do a similar stumble. If I don't press the clutch fast enough, it will die.
    3) Once driving, if the engine gets lugged down below 2000rpm, up a hill, with heavy pedal, it will start to stutter. Almost like the ignition is missing.

    There are no codes.

    I have done a Google search and numerous Ford and Ranger forums have described similar symptoms, but there doesn't seem to be a definitive resolution. Some searching have led to Ford service bulletin #05-22-12. It applies to numerous vehicles, including my truck. More info found here:

    https://repairpal.com/engine-buckmis...way-speeds-934

    Since this engine does not have a cam synch assembly, does this mean possible cam sensor issue? We did replace the crank sensor.

    It may have been easier to do a LS swap...LOL

    As always, any suggestion is appreciated.

    Andrew
    Last edited by andrewb70; 06-30-2018 at 01:59 PM.
    1970 GTO Version 2.0
    1967 Cougar build
    GM High-Tech Performance feature
    My YouTube Channel Please Subscribe!

    "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her


  3. #23
    Join Date
    Apr 2001
    Location
    The Druid City
    Posts
    13,463
    Country Flag: United States

    Default

    I swapped out the MAF and that made a huge difference. The stumble off idle is way better.

    However, I was driving up a hill in 5th and under high load and around 2000rpm, the bucking is still happening. It feels as if the computer is detecting knock and pulling timing. I researched this scenario and it turns out that these engines don't have a knock sensor. These are low compression engines and 87 fuel is recommended. Apparently Ford programmed a very conservative timing strategy and did not need knock sensors. This doesn't surprise me for a little truck.

    So I don't think it is knock...

    Others have suggested the TPS might have "dead spots." I tested the TPS and it does seem to be a little "lazy" right at initial tip in. These engines don't have a MAP sensor, so the "accelerator pump" is a function of actual air flow (MAF) and TPS.

    I have a new TPS sensor but I have not installed it yet. I can see how it might further help taking off from a stop, but I fail to see how it might fix the bucking at high load...

    Thoughts?

    Andrew
    1970 GTO Version 2.0
    1967 Cougar build
    GM High-Tech Performance feature
    My YouTube Channel Please Subscribe!

    "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her


  4. #24
    Join Date
    Sep 2006
    Location
    Southern Indiana
    Posts
    4,609
    Country Flag: United States

    Default

    Had a ford ranger that would buck and die underload, start right back up. If the scanner was in data mode it was just like it wasnt running but coasting in gear it looked like it was running. Turns out it was very simple the "new" cheap wires and plugs failed. Swapped in new motorcraft plugs and Napa belden wires and issue went away.
    Lee Abel
    AFTERMARKET PERFORMANCE

    1977 Chevy Monza 2+2:Project "Cheap Trick"
    1978 C10 Long bed , On air and trailer puller
    2006 Buell Blast ,Just a bike to ride and for mileage
    1966 Caprice 4dr Sports Roof fact.327/now 350/SOON 454???? Project "II Old,,,ZERO BUDGET OR LESS CAPRICE!"

  5. #25
    Join Date
    Oct 2011
    Posts
    164

    Default

    What about your coils? Are they new when you rebuilt the engine? Might be a bad coil or bad connection.

  6. #26
    Join Date
    Apr 2001
    Location
    The Druid City
    Posts
    13,463
    Country Flag: United States

    Default

    The coils are new, made by Delphi. I new wires are AC Delco. New plugs are Denso Iridium, all 8 of them. I can't imagine these would qualify as "cheap" parts, but anything is possible.



    Andrew
    1970 GTO Version 2.0
    1967 Cougar build
    GM High-Tech Performance feature
    My YouTube Channel Please Subscribe!

    "You were the gun, your voice was the trigger, your bravery was the barrel, your eyes were the bullets." ~ Her



Page 2 of 2 FirstFirst 1 2


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •