PDA

View Full Version : Procharger with power steering issues - help!



rsssconv
02-08-2010, 12:13 PM
I have searched and searched but have not found anything that can help my situation.

I have a 67 Camaro with a small block. I bought a Procharger D1SC system for my new forged 383. My issue is the power steering; ATI offers a bracket kit for a gen 2 pump which has an idler pulley. I have read that the idler stresses the belt and only lasts about 500 miles. Some have run different belts such as the green and solid in order to last a little longer but this is not acceptable to me.

Is there another setup out there that will work? What are you guys doing out there?

The center of the power steering pulley needs to be 3.25" off the face of the block which creates an issue. Can the ATI brackets be modified so the pump can swivel?

Please help, I can fabricate if someone has some ideas.

Thanks,
Mark

anarchy99
02-09-2010, 07:01 AM
I use the ATI bracket you are talking about without any issues. Probably only 1000 miles on the setup right now. The bracket with the supplied belt whined pretty bad and couldn't get tight enough. I swapped the belt for the next smallest one down and it works like a charm!

rsssconv
02-09-2010, 11:06 AM
Thanks for the response. I am probably going in that direction and will have to play around with some belts. I will also need to find the shortest belt so it can also have less back bend too.

anarchy99
02-09-2010, 05:17 PM
The next smallest gates belt down from the one they send you is the perfect fit. Nothing smaller will fit. you actually have to unbolt the pump from the block to get it on there, then bolt everything back up. not much back bend at all. I was running the belt that it came with before going to the smaller one, and it's too long and caused the tensioner to contact the pulley, and still wasn't tight enough causing annoying whining from the pump pulley.

rsssconv
02-09-2010, 06:52 PM
Thanks!

DFRESH
02-10-2010, 08:58 PM
Could you put up pictures of the setup---I have yet to see ATI's brackets (running AC, Alt and PS) and am wondering how it packages once in the car. Am seriously considering going this direction--just don't want to have to fab up a bunch of extra supports to make it all work the way it is suppossed to. Thanks if you can put some up!

Doug

anarchy99
02-11-2010, 07:47 AM
https://static1.pt-content.com/images/pt/2010/02/IMG_04891-1.jpg

Sorry for only one pic. I'm not around my car right now.

DFRESH
02-12-2010, 10:44 PM
Are you also running AC (I'm assuming you are using an Alternator as well right?). Do you have a pic of the other side of the motor?

Doug

anarchy99
02-13-2010, 06:39 PM
other side of the motor is normal. Alternator up high. I have the stuff for the AC I just need to get the bracket from procharger that mounts the AC up high and alternator down lower. I'd be in the hurt locker without an alternator.
https://static1.pt-content.com/images/pt/2010/02/IMG_0552-1.jpg

rsssconv
02-16-2010, 05:24 PM
I just received the bracket kit today. It even came with the belt and the PS fitting. The quality looks excellent. Next I will need to buy a Gen. 2 unit. I suppose I will get one with the straight fitting, any recommendations on that?

What are you guys using for a resevoir? I am looking into the Zoops.

I will post pictures once I get all the parts.

Norwoodx55
02-16-2010, 06:05 PM
other side of the motor is normal. Alternator up high. I have the stuff for the AC I just need to get the bracket from procharger that mounts the AC up high and alternator down lower. I'd be in the hurt locker without an alternator.
https://static1.pt-content.com/images/pt/2010/02/IMG_0552-1.jpg
Curious here, I have never seen the hose from the top of the water pump to the intake on a SBC before, what is that all about? Also, all you ProCharger guys, are you using short or long water pumps.
Brett

rsssconv
02-16-2010, 06:45 PM
If you are not going to use your heater, you would use a by-pass hose like the one in the picture.

Procharger system for the SBC uses the long style pump.

Norwoodx55
02-16-2010, 08:48 PM
Gotcha, thanks.

rsssconv
02-17-2010, 12:17 PM
Here are some pics.



https://static1.pt-content.com/images/noimg.gif
SB Chevy kit for $170 shipped from ATI
https://static1.pt-content.com/images/noimg.gif
https://static1.pt-content.com/images/noimg.gif
https://static1.pt-content.com/images/noimg.gif
Mocked up real quick.

DFRESH
02-21-2010, 07:25 PM
Very helpful---thanks for posting. Please keep the pics coming, especially when you get the Type II pump mounted up.

Doug

slownova73
02-22-2010, 08:40 PM
yes!! as many pics of the PS pump setup as possible please, gonna need this info for the future build!

anarchy99
02-23-2010, 12:45 AM
the belt they sent with my kit was the same as the one pictured and I had to go to the next smallest size gates belt down. I think a half inch shorter. You might want to test fit your belt a pulley setup before getting everything in the car since it looks like it's all out right now.