View Full Version : Wiring HI-6 igniton box + Pertronix Ignitor II?

01-16-2009, 12:15 AM
Here's the deal my vacuum advance, points style distributor was up graded with Pertronix Ignitor II (pn:PNX-91181) and Flame Thrower II coil (pn:PNX-45011). I got a deal on an older model HI-6 (pn:6000-6420) but I am confused as to how to hook it up. I downloaded Crane's installation instructions but should I follow the points based diagram or the magnetic trigger hookup? My car hs a Chevy 350.

Thanks in advance.

01-16-2009, 03:00 PM

01-17-2009, 03:03 PM
Found this http://www.fordmuscle.com/forums/all-ford-techboard/438631-crane-hi-6-pertronix-ignitor.html might work. If not I would call pertronix.

01-17-2009, 06:37 PM
Just ditch the Pertronix and use MSD distributor and MSD coil, much better performance at higher RPM also very reliable.. MSD stuff works very well as a complete system.. I ditched my Pertronix and swicthed to MSD 6AL, HVC coil and MSD distributor (8556)..Instant difference, even at idle...

02-18-2009, 03:47 PM
Ended up using the points diagram and instructions, installation was easy. It started right up (first crank) usually takes five or six with the Pertronix setup. It idled fine but when I hit the gas it stumbles and misses really bad. The ignition box shows no error codes and I followed the instructions to a tee, doubled and triple checked everything. Even made sure to seperate coil wires from other wires and also hooked it up following the magnetic hookup instructions, it not start of course (got desperate). Car ran fine before the HI-6, Initial timing is set to 10 degress BTDC with a total of 35 coming in at 3000 rpm. What could cause it to miss fire so bad under load? Maybe my coil is not compatible with the HI-6 (using Pertonix Flame Thrower II)?

Please help getting desperate.

02-18-2009, 05:14 PM
Wonder if now we know why you got such a good deal on the Hi 6 unit.:pat:

02-18-2009, 05:33 PM
What port is your vacuum advance hooked up to? If you have it hooked to full vacuum at idle, it will be maxed out & actually retard the timing as your throttle blade passes the transfer slot.

02-19-2009, 11:40 AM
I'm running an Edlebrock carb and use the vacuum port located on the passenger side. Before the installation my car ran perfect. Does anybody know if the Pertronix coil is compatible with the HI-6? I checked Crane's website but they don't have a listing for Pertronix products.

I would think that if the ignition box was at fault the car would not start at all. Maybe my good deal wasn't so good. Oh well at least I didn't pay much.