View Full Version : qa1 coilover rod end failures?

05-29-2008, 06:14 PM
Hi- curious if anyone else has had issues with the plastic and metal 'heim' type inserts that come on the qa-1 coilovers? (not the rubber/urethane ones); I just changed my front coilovers from an older set of pro's to the qa-1 to match the rears on my car, took it to one autocross and back home and both front shocks had the plastic litterally blown apart- even pushed out the snap rings. (I'll post pics tommorow) I've emailed qa1, but haven't heard back, now I'm off the road for another weekend...

I guess if you're not breaking anything you aren't pushing it hard enough, but this is a bit much.

05-30-2008, 04:57 AM
pic attached

05-30-2008, 05:51 AM
Do you have a picture of it installed and/or articulated? It almost looks like it exceeded the range of motion for that design of spherical bearing and the standoffs crushed the outer portion of the liner.


05-30-2008, 09:26 AM
If they fit, I suggest using FK inserts. They're for 1.000" diameter bores.

05-30-2008, 02:06 PM
I've re-ordered the all-steel versions; but I figure it might be worth keeping an eye on if anyone else is using these. I'll upload a suspension pic later, but there is a pic with the old shock in my pt garage. Definately no bind or range of motion problem, I dry fit it without the springs to be sure. -Dan

Motown 454
05-30-2008, 02:54 PM
Thats good to know scince I'm ordering shocks soon

05-30-2008, 03:46 PM
glad i got the bushing ends for mine, but make sure there isnt any binding anywhere