View Full Version : Gah, this Hobart welder is pissing me off!

01-07-2008, 05:17 PM
I used it for about 30 minutes and the circuit board went bad on it. Just a click and no wire feed. Hobart fixed it under warranty although it took me two weeks to get it back. I have used it maybe an hour or two since. Tonight I went out to weld on the spring perched on my mockup axle so I can get the suspension and frame installed in the Patriot Dream car, and CLICK - same ****ing problem.

I had planned on having the rear suspension and frame done this weekend and then the front suspension done next week and have it rolling soon, but now looks like the welder is going back for warranty work again.

I am pissed, Shawn is now coming home a month early and I just lost two more weeks on the car. :machine:

01-07-2008, 05:20 PM
most lincoln/miller repair places have lenders they lend out, i would check into it,

01-07-2008, 05:30 PM
Jake, they better this time. Last time they told me they didn't have any.

01-07-2008, 06:43 PM
I have a 140 and they sent me new parts right away,

01-07-2008, 07:09 PM
Thermadyne baby.
Or my old reliable Astro Pneumatic

01-07-2008, 07:26 PM

01-07-2008, 07:28 PM
Also for smaller jobs Thermadyne has a unit called the Dragster 85 very sweet 110 Tig

01-07-2008, 07:35 PM
What's the duty cycle of that unit? Duty cycles on welders are based on 10 min increments, 30% duty cycle = 3 Mins continuous use.


01-08-2008, 04:08 AM
I am not sure, but I've just been tack welding. It has never really seen more than one minute of continuous use. Last night I literally welded for about 15 seconds before it crapped out.